Breaking News Bar
posted: 8/19/2012 5:02 AM

Fuel gauge, fuel pump still not connecting

hello
Success - Article sent! close
 

I recently received a follow-up question from the driver of a Pontiac Montana minivan whose fuel gauge was malfunctioning, always reading full. I had recommended he use a scan tool to measure the signal coming from the fuel sending unit on the fuel pump.

Q. I finally got around to looking into your advice on the weird behavior of our Montana. I unplugged the connector coming from the fuel tank and put an ohm meter between the purple wire (upper end of the sending unit) and the black/white wire (lower end of the sending unit) going to the PCM (protection circuit module). I read an open (ůvery strange). But when I rocked the van, the resistance was changing as the gas was sloshing around. After several seconds the ohm meter once again read open.

Order Reprint Print Article
 
Interested in reusing this article?
Custom reprints are a powerful and strategic way to share your article with customers, employees and prospects.
The YGS Group provides digital and printed reprint services for Daily Herald. Complete the form to the right and a reprint consultant will contact you to discuss how you can reuse this article.
Need more information about reprints? Visit our Reprints Section for more details.

Contact information ( * required )

Success - request sent close

Unfortunately I only had access to a digital meter that doesn't give as precise a reading as an analog meter would. I guess when the van sits still for several moments (open sending unit reading), the PCM must interpret it as being low on fuel. I guess as long as the van is moving and the gas is sloshing around, the resistance is never steady long enough for the PCM to give an "empty" reading, probably averaging it out. Apparently the sending unit is really not broken considering it does show resistance in certain situations.

I could always try putting a variable resistor on the PCM side of that connector to see if I can get the gauge to change. I've heard of some gasoline additives that would clean up the resistance wire that has been corroded, if you could call it that. Any idea about additives that could possibly remedy this problem?

The other thing I've heard is that this occurs when using Shell gasoline, which we do. Any truth to that theory?

A. It is starting to sound like you are dealing with a bad sending unit. It is a very common failure item on your vehicle.

If the vehicle has some miles on it, the replacement of the fuel pump/sending unit may not be a bad idea because sooner or later the pump will fail, too. If Murphy's Law has anything to say about it, the pump will fail at the worst possible time, so you may as well kill two birds with one stone.

To ease your mind before installing the pump, you could plug it in, disconnect the pump portion, and test the gauge to be sure you are solving the gauge problem. There is no additive that will fix this problem and I have not heard of a certain brand of fuel contributing to the failure of a sending unit. I use Shell gasoline personally and have had no problems with it. Let me know how this turns out.

• Douglas Automotive is at 312 S. Hager Ave., Barrington, (847) 381-0454, and 123 Virginia Road, Crystal Lake, (815) 356-0440. For information, visit douglasautomotive.com. Send questions to underthehood@dailyherald.com.

Share this page
Comments ()
Guidelines: Keep it civil and on topic; no profanity, vulgarity, slurs or personal attacks. People who harass others or joke about tragedies will be blocked. If a comment violates these standards or our terms of service, click the X in the upper right corner of the comment box. To find our more, read our FAQ.
    help here